Recent Activity

Activity stream for all registered members at Chevy Cobalt Forum - Cobalt SS | Cruze | Saturn ION | Pontiac G5 Forum.

  1. joeE52 replied to the thread no fuel pressure at rail..

    I have a similar situation. Did you find a solution? I have 2v at the fuel pump relay. Sent from my moto e5 cruise using Tapatalk

    Dec 8, 2019 at 9:50 PM
  2. joeE52 replied to the thread Cobalt 2006 NO START after removal of ecm.

    I'm having similar problems. Did you check power at the fuel pump relay? I'm only getting 2v coming from the ECM. I can't figure out/pin...

    Dec 8, 2019 at 9:47 PM
  3. Itjustruns replied to the thread 06 Cobalt LS, No Crank No Start and Weird Electrical Issues.

    Update! I've torn the car apart and checked many things. I checked common grounds, security, and the rest of the fuses on the car. I'm...

    Dec 6, 2019 at 3:26 PM
  4. Helixal replied to the thread Cobalt 2006 NO START after removal of ecm.

    Fully charged the battery from 38% to 100% still no start. I don’t hear the fuel pump but the engine turns over. Probably no spark...

    Dec 5, 2019 at 12:23 PM
  5. five7man replied to the thread 2005 Cobalt LS Stuck Rack&Pinion(Trouble with Removal).

    Lol, I do like cookies!!!! Glad to be of help.

    Dec 4, 2019 at 11:57 AM
  6. qualitypest20 set their home page.

    http://www.qualitypestcontrolandmaintenance.com.au/

    Dec 3, 2019 at 1:23 PM
  7. Shadow9198 posted a new thread.

    Engine power reduced/engine disabled

    Hey guys, so I'm having an issue with my 2006 cobalt coupe 5 speed 2.2L. While driving it will sometimes come up with the engine power...

    Forum: LS, LT, LTZ

    Dec 3, 2019 at 9:43 AM
Loading...