HEAD LIGHTS

Discussion in 'General Discussion' started by jaamik, Mar 12, 2017.

  1. jaamik

    jaamik Junior Member

    Posts:
    4
    Likes Received:
    0
    Joined:
    Mar 12, 2017
    Location:
    texas
    I installed complete head light assemblies on both sides of my 2005 Cobalt. I have checked fuses and connections but still don't have low beams either side. I read someplace that in this case the relay that controls the head lights is in the fuse box base. Is this correct? Many thanks.....mike
     
  2. five7man

    five7man Junior Member

    Posts:
    7
    Likes Received:
    4
    Joined:
    Feb 21, 2015
    Headlights-Daytime Running Lights (DRL) Schematics.gif
     
  3. jaamik

    jaamik Junior Member

    Posts:
    4
    Likes Received:
    0
    Joined:
    Mar 12, 2017
    Location:
    texas
    Thanks, five7man..............seems there is a relay under the hood tht controls both sides..........I'll check it out.........thanks, again........Mike
     
  4. pawntec

    pawntec Junior Member

    Posts:
    6
    Likes Received:
    0
    Joined:
    Feb 11, 2010

    Did you upgrade the headlights or just installed the factory housings and standard 9007 bulbs?
     
  5. jaamik

    jaamik Junior Member

    Posts:
    4
    Likes Received:
    0
    Joined:
    Mar 12, 2017
    Location:
    texas
    I'll have to check it out. It's my grandsons care and he bought the parts. I don't know if the parts are aftermarket or OEM....thanks for the reply..........mike
     
  6. jaamik

    jaamik Junior Member

    Posts:
    4
    Likes Received:
    0
    Joined:
    Mar 12, 2017
    Location:
    texas
    thanks for the schematic five7man............I need a "fuse block" that contains the low beam relay
     
  7. munron

    munron Junior Member

    Posts:
    5
    Likes Received:
    1
    Joined:
    Aug 6, 2016
    Location:
    Armstrong, BC
    Sounds like both bulbs are burned out. Have you tried new ones?
     
  8. john intili

    john intili Junior Member

    Posts:
    3
    Likes Received:
    0
    Joined:
    Sep 28, 2017
    Location:
    New Jersey
    I have recently experienced a no high beam condition, however in the DRL mode, i can flash to pass and they come on, so it appears that maybe the switch at the column is faulty. I need to check the relay and fuse for high beams. I did install higher wattage bulbs a few months ago.
    BTW its a 2009 LS XFE
     

Share This Page