2009 Cobalt LT FALLS EDITION (OFFICIAL TEAM CANADA OLYMPIC 2010 VEHICLE) Timing (?) Issue: Gear Symbol light with plus symbol inside of it

Danimal

Junior Member
Joined
Jan 20, 2024
Posts
1
Reaction score
0
Location
Saint John, New Brunswick, Canada
Am having a problem with my 09 Falls Edition Cobalt LT. 5spd manual, 286,xxx km (not miles - Canadian) on the ODO. I am not 100% sure if it is what I think it is, but under heavy acceleration and/or higher RPM, I get a circular gear-like symbol, with a plus symbol inside of it. It goes away, and it only happens intermittently. I experience no symptoms, feeling nothing out of the ordinary, nothing weird. I think the symbol relates to something with the timing/chain, but I could be wrong. If I'm correct about what the sensor light is, could my Timing be starting to slip or jump or gone advanced/retarded? (Clarify for society, I don't mean the slur. I mean the mechanical term for being behind in something, IE Timing being delayed/behind, etc. Since I am a mechanic, I just haven't dealt with a light like this before). Advice and help appreciated, thanks y'all.
 

SideShow Bob

Full Access Member
Joined
Jul 25, 2019
Posts
50
Reaction score
4
Location
CO.
but under heavy acceleration and/or higher RPM, I get a circular gear-like symbol, with a plus symbol inside of it. It goes away, and it only happens intermittently. I experience no symptoms,
That is your upshift symbol.

A mechanic……… OK……..
 

Members online

Forum statistics

Threads
7,432
Posts
156,460
Members
4,338
Latest member
LokiPMustDie
Top