Help No tail lights or cluster lights

Discussion in 'Electrical, audio, video' started by sdjk_2001, Mar 22, 2013.

  1. sdjk_2001

    sdjk_2001 Junior Member

    Posts:
    1
    Likes Received:
    0
    Joined:
    Mar 22, 2013
    Hey There guys i have a 2007 cobalt ss with hid headlights and led taillights and i have no taillights or dash lights. shortly after i in stalled my hids (about a year ago) i lost my cluster lights. Just bought the stick on led lights to fix that problem. Notice last weekend i had no running lights in the back at night. Turn signals and brake lights work just not the running lamp or license plate light. I have checked all the fuses, and even switch the headlight switch. i have also swap out led lights and hids thinking that was the problem. Took it to my mechanic and he said he changed a fuseable link thinking that might be the problem but it wasn't. Does anyone have any idea what the problem is???
     
  2. Bass_Waves

    Bass_Waves Full Access Member

    Age:
    31
    Posts:
    2,077
    Likes Received:
    0
    Joined:
    Jul 22, 2012
    Hmmm maybe something fried up using hid kits. Dunno much on these cobalts yet. I have yet to encounter much problems

    Sent from my DROID RAZR HD using Tapatalk 2
     
  3. YelloEye

    YelloEye Super Moderator Staff Member

    Posts:
    7,601
    Likes Received:
    23
    Joined:
    Jul 18, 2009
    Location:
    Renton, WA
    Sounds like you popped a fuse somewhere or shorted something. Try going back to stock lights and housings and narrow it down from there.
     

Share This Page